Multicast listener discovery, MLD — протокол стека IPv6, встроенный в ICMPv6 и использующийся для определения получателей мультивещательных запросов (). Аналогичную роль в стеке протоколов IPv4 выполняет протокол IGMP: MLDv1 похож на IGMPv2, а MLDv2 аналогичен IGMPv3. Первая версия протокола (MLDv1) описана в RFC 2710, вторая (MLDv2) — в RFC 3810 и обновляющем его RFC 4604.
Поддержка в ОС Протокол MLDv2 поддерживается операционными системами: Windows Vista и более поздними (с версии 6.0), FreeBSD — с версии 8.0, ядром Linux — с версии 2.5.68. Примечания
Литература
RFC 2710 : Multicast Listener Discovery (MLD) for IPv6. — 1999. — RFC 3810 : Multicast Listener Discovery Version 2 (MLDv2) for IPv6. — 2004. — RFC 4605 : Internet Group Management Protocol (IGMP) / Multicast Listener Discovery (MLD)-Based Multicast Forwarding ("IGMP/MLD Proxying").
Ссылки
"MLD and IGMP Using Windows Sockets". Windows Sockets 2. 2011-09-16. "mld(4): Multicast Listener Discovery Protocol". FreeBSD Kernel Interfaces Manual. 2009-05-27. Torvalds, L. Linux 2.5.68 ChangeLog : . — 2003. — Apr 19.
Категория:TCP/IP Категория:Протоколы сетевого уровня Категория:Интернет-протоколы