Есть множество стандартов, относящихся к криптографии.

Стандарты шифрования Data Encryption Standard (DES, устарел) Triple-DES Advanced Encryption Standard (AES) RSA исходный алгоритм открытого ключа OpenPGP CipherSaber

Стандарты хеширования MD5 128-bit (устаревающий) SHA доступен в вариантах 160 (устарел), 256, 384 и 512-бит HMAC PBKDF2 (RFC 2898)

Стандарты цифровой подписи Digital Signature Standard (DSS), based on the Digital Signature Algorithm (DSA) RSA

Стандарты инфраструктуры открытых ключей (PKI) X.509 Public Key Certificates

Стандарты беспроводных коммуникаций Wired Equivalent Privacy (WEP), заменён WPA Wi-Fi Protected Access (WPA), улучшенная версия WEP IEEE 802.11i-2004 a.k.a. WPA2, используется AES A5/1 и A5/2 шифрование для телефонов в системе GSM

Американские стандарты (FIPS) FIPS PUB 31 Guidelines for Automatic Data Processing Physical Security and Risk Management 1974 FIPS PUB 46-3 Data Encryption Standard (DES) 1999 FIPS PUB 73 Guidelines for Security of Computer Applications 1980 FIPS PUB 74 Guidelines for Implementing and Using the NBS Data Encryption Standard 1981 FIPS PUB 81 DES Modes of Operation 1980 FIPS PUB 102 Guideline for Computer Security Certification and Accreditation 1983 FIPS PUB 112 Password Usage 1985, defines 10 factors to be considered in access control systems that are based on passwords FIPS PUB 113 Computer Data Authentication 1985, specifies a Data Authentication Algorithm (DAA) based on DES, adopted by the Department of Treasury and the banking community to protect electronic fund transfers. FIPS PUB 140-2 Security Requirements for Cryptographic Modules 2001, defines four increasing security levels FIPS PUB 171 Key Management Using ANSI X9.17 (ANSI X9.17-1985) 1992, based on DES FIPS PUB 180-4 Secure Hash Standard (SHS) 2012 defines the SHA family FIPS PUB 181 Automated Password Generator (APG) 1993 FIPS PUB 185 Escrowed Encryption Standard (EES) 1994, a key escrow system that provides for decryption of telecommunications when lawfully authorized. FIPS PUB 186-2 Digital Signature Standard (DSS) 2000 FIPS PUB 190 Guideline for the Use of Advanced Authentication Technology Alternatives 1994 FIPS PUB 191 Guideline for the Analysis of local area network Security 1994 FIPS PUB 196 Entity Authentication Using Public Key Cryptography 1997 FIPS PUB 197 Advanced Encryption Standard (AES) 2001 FIPS PUB 198 The Keyed-Hash Message Authentication Code (HMAC) 2002 FIPS PUB 202 SHA-3 Standard 2015 defines the SHA-3 hash function

Стандарты СНГ (ГОСТ) ГОСТ 28147-89. Системы обработки информации. Защита криптографическая. Алгоритм криптографического преобразования ГОСТ 34.10-2018. Информационная технология. Криптографическая защита информации. Процессы формирования и проверки электронной цифровой подписи ГОСТ 34.11-2018. Информационная технология. Криптографическая защита информации. Функция хеширования ГОСТ 34.12-2018. Информационная технология. Криптографическая защита информации. Блочные шифры ГОСТ 34.13-2018. Информационная технология. Криптографическая защита информации. Режимы работы блочных шифров

Стандарты Украины (ДСТУ) ДСТУ 4145-2002. Информационные технологии. Криптографическая защита информации. Цифровая подпись, основанная на эллиптических кривых. Формирование и проверка ДСТУ 7624:2014. Інформаційні технології. Криптографічний захист інформації. Алгоритм симетричного блокового перетворення ДСТУ 7564:2014. Інформаційні технології. Криптографічний захист інформації. Функція хешування

Интернет Requests for Comments (RFCs) RFC 4357 Additional Cryptographic Algorithms for Use with GOST 28147-89, GOST R 34.10-94, GOST R 34.10-2001, and GOST R 34.11-94 Algorithms RFC 4491 Using the GOST R 34.10-94, GOST R 34.10-2001, and GOST R 34.11-94 Algorithms with the Internet X.509 Public Key Infrastructure RFC 5830 GOST 28147-89: Encryption, Decryption, and Message Authentication Code (MAC) Algorithms RFC 5831 GOST R 34.11-94: Hash Function Algorithm RFC 5832 GOST R 34.10-2001: Digital Signature Algorithm RFC 6986 GOST R 34.11-2012: Hash Function RFC 7091 GOST R 34.10-2012: Digital Signature Algorithm RFC 7801 GOST R 34.12-2015: Block Cipher "Kuznyechik" RFC 8891 GOST R 34.12-2015: Block Cipher "Magma" RFC 7836 Guidelines on the Cryptographic Algorithms to Accompany the Usage of Standards GOST R 34.10-2012 and GOST R 34.11-2012 RFC 8133 The Security Evaluated Standardized Password-Authenticated Key Exchange (SESPAKE) Protocol RFC 1991 PGP Message Exchange Formats (obsolete) RFC 2440 OpenPGP Message Format (obsolete) RFC 4880 OpenPGP Message Format RFC 5581 The Camellia Cipher in OpenPGP RFC 6637 Elliptic Curve Cryptography (ECC) in OpenPGP RFC 2015 MIME Security with Pretty Good Privacy (PGP) RFC 3156 MIME Security with OpenPGP

Секретные стандарты EKMS NSA's Electronic Key Management System FNBDT NSA's secure narrow band voice standard Fortezza encryption based on portable crypto token in PC Card format STE secure telephone STU-III older secure telephone TEMPEST prevents compromising emanations

Другие IPsec Virtual Private Network (VPN) and more IEEE P1363 covers most aspects of public-key cryptography Transport Layer Security (formerly SSL) SSH secure Telnet and more Content Scrambling System (CSS, the DVD encryption standard, broken by DeCSS) Kerberos authentication standard RADIUS authentication standard ANSI X9.59 electronic payment standard Common Criteria Trusted operating system standard CRYPTREC Japanese Government’s cryptography recommendations

Ссылки Криптография: Основные принципы, стандарты и применение шифрования данных

Категория:Стандарты криптографии