Jitsi è una raccolta di applicazioni di messaggistica multipiattaforma (VoIP), videoconferenze e messaggistica istantanea libere e open source (FOSS) per la piattaforma web, Windows, Linux, macOS, iOS e Android. Il progetto Jitsi è iniziato con il desktop Jitsi (precedentemente noto come SIP Communicator). Con la crescita di WebRTC, l'attenzione del team del progetto si è spostata sul Jitsi Video Bridge per consentire le videochiamate multi-party basate sul Web. Successivamente il team ha aggiunto Jitsi Meet, un'applicazione di videoconferenza completa, che include client Web, Android e iOS. Jitsi gestisce anche meet.jit.si, una versione di Jitsi Meet ospitata da Jitsi per uso gratuito della comunità. Altri progetti includono; Jigasi, lib-jitsi-meet, Jidesha e Jitsi.

Jitsi ha ricevuto il sostegno di varie istituzioni come la Fondazione NLnet, l'Università di Strasburgo e la Regione dell'Alsazia e ha anche avuto molteplici partecipazioni al programma Google Summer of Code.

Storia Il lavoro su Jitsi (allora SIP Communicator) è iniziato nel 2003 nell'ambito di un progetto studentesco di Emil Ivov presso l'Università di Strasburgo. È stato originariamente rilasciato come un esempio di video-telefono nello stack JAIN-SIP e successivamente si è distaccato come progetto autonomo.

Nel 2009, Emil Ivov ha fondato la società BlueJimp, che ha impiegato alcuni dei principali contributori di Jitsi al fine di offrire supporto professionale e servizi di sviluppo relativi al progetto.

Nel 2011, dopo aver aggiunto con successo il supporto per la comunicazione audio/video sulle Jingle extensions di XMPP, il progetto è stato rinominato in Jitsi, poiché non era più "un sistema di comunicazione basato solo su SIP". Questo nome ha origine dal Bulgaro “жици” (fili).

Jitsi ha introdotto il Video Bridge nel 2013 per supportare le videochiamate multiparte con i suoi client Jitsi, utilizzando una nuova architettura SFU (Selective Forwarding Unit). Nel seguito dello stesso anno è stato aggiunto il supporto iniziale al Jitsi Videobridge permettendo chiamata WebRTC dal browser. Per dimostrare come Jitsi Videobridge potesse essere utilizzato come servizio effettivo, BlueJimp offrì un uso gratuito del suo sistema ospitato nel sito meet.jit.si.

Il 4 novembre 2014, "Jitsi + Ostel" ha ottenuto sei punti su sette nella scorecard di messaggistica sicura della Electronic Frontier Foundation. Ha perso un punto perché non c'era stato un recente audit indipendente del codice.

Il 1 febbraio 2015, Hristo Terezov, Ingo Bauersachs e il resto del team hanno rilasciato la versione 2.6 dal loro stand all'incontro europeo degli sviluppatori di software liberi e open source a Bruxelles (FOSDEM). Questa versione include correzioni di sicurezza, rimuove il supporto del protocollo MSN deprecato, insieme a SSLv3 in XMPP. Tra gli altri miglioramenti notevoli, la versione di OS X incorpora un runtime Java 8, abilita l'annullamento dell'eco per impostazione predefinita e utilizza il sottosistema CoreAudio. La build Linux risolve i problemi di font con il LookAndFeel nativo di GTK, e risolve alcuni problemi di lunga data sul livello del microfono durante la configurazione delle chiamate quando si utilizza il sistema audio PulseAudio. Questa versione aggiunge anche il database Java incorporato Hyper SQL Database per migliorare le prestazioni per gli utenti con file di configurazione di grandi dimensioni, una funzionalità che è disabilitata per impostazione predefinita. Un elenco completo delle modifiche è disponibile sul sito web del progetto.

Atlassian ha acquisito BlueJimp il 5 aprile 2015. Dopo l'acquisizione, il nuovo team di Jitsi sotto Atlassian cessò nuovi significativi lavori di sviluppo sul progetto Jitsi Desktop e ampliò i suoi sforzi su progetti relativi a Jitsi Videobridge e a Jitsi Meet. I contributi regolari della comunità open source hanno mantenuto il progetto Jitsi Desktop.

Jitsi è interamente finanziato da 8x8 che lo ha acquistato nel 2018.

Progetti primari di Jitsi Il repository open source Jitsi su GitHub contiene attualmente 103 repository. I principali progetti comprendono:

Jitsi Meet – server di videoconferenza progettato per l'installazione rapida sui server Debian/Ubuntu Jitsi Videobridge – Motore dell'unità di inoltro selettivo WebRTC per l'alimentazione di conferenze multipartitiche Jigasi – applicazione lato server che collega i client SIP regolari a partecipare alle conferenze Jitsi Meet ospitate da Jitsi Videobridge. lib-jitsi-meet – Un'API JavaScript di basso livello per fornire un'interfaccia utente personalizzata per Jitsi Meet Jidesha – un'estensione di Chrome per Jitsi Meet Jitsi: comunicatore audio, video e chat che supporta protocolli quali SIP, XMPP/Jabber, AIM/ICQ e IRC

Jitsi Meet

Si tratta di un'applicazione JavaScript WebRTC open source e può essere utilizzato per la videoconferenza. Si può condividere desktop e presentazioni e con un solo link può invitare nuovi membri per la videoconferenza. Può essere utilizzato scaricando l'app oppure direttamente tramite browser Chrome. Ogni utente può utilizzare i server Jitsi.org o può scaricare e installare il proprio server su Linux.

Caratteristiche principali di Jitsi Meet Comunicazione crittografata (comunicazione protetta) Nessuna necessità di nuova installazione del software client

Jitsi Videobridge Si tratta di una soluzione di videoconferenza che supporta WebRTC che consente la comunicazione video multiutente. Si tratta di un'unità di inoltro selettivo (SFU) e inoltra solo i flussi selezionati ad altri utenti partecipanti alla videoconferenza, pertanto, la potenza della CPU non è così critica per le prestazioni.

Jitsi Desktop Jitsi ha generato alcuni progetti fratelli come Jitsi Video Bridge Selective Forwarding Unit (SFU) e Jitsi Meet, un'applicazione per videoconferenze e web. Per evitare confusione con la crescente popolarità con questi altri progetti Jitsi, l'applicazione client Jitsi è stata rinominata come Jitsi Desktop.

Originariamente il progetto è stato utilizzato principalmente come strumento di sperimentazione a causa del suo supporto per IPv6. Nel corso degli anni, quando il progetto ha raccolto membri, ha anche aggiunto il supporto per protocolli diversi da SIP.

Caratteristiche Jitsi supporta più sistemi operativi, tra cui Windows e sistemi Unix come Linux, Mac OS X e BSD. Le app per dispositivi mobili possono essere scaricate sull'App Store per iOS e sulla piattaforma Google Play Store e F-droid per Android. Include inoltre:

Trasferimento di chiamata Auto away Riconnessione automatica Risposta automatica e Inoltro automatico Registrazione delle chiamate Crittografia delle chiamate con SRTP e ZRTP Conferenze telefoniche Connessione diretta dei media con il protocollo ICE Desktop Streaming Archiviazione delle password crittografata con una master password Trasferimento di file per XMPP, AIM/ICQ, Windows Live Messenger, YIM Crittografia istantanea della messaggistica con OTR (crittografata end-to-end) Supporto IPv6 per SIP e XMPP Inoltro del media con il protocollo TURN Indicazione di messaggio in attesa (RFC 3842) Chiamate vocali e video per SIP e XMPP con H.264 e H.263 o VP8 per la codifica video Audio a banda larga con SILK, G.722, Speex e Opus Supporto DTMF con SIP INFO, RTP (RFC 2833/RFC 4733), In-band Zeroconf via mDNS/DNS-SD (alla Apple's Bonjour) DNSSEC Supporto video di gruppo (Jitsi Videobridge) Occultamento della perdita di pacchetti con i codec SILK e Opus

Utilizzatori Jitsi è utilizzato da numerose società ed enti tra cui:

Note

Voci correlate Comparazione degli instant messenger Confronto tra software di VoIP Session Initiation Protocol

Altri progetti

Collegamenti esterni

Categoria:Messaggistica istantanea Categoria:Iniziative collaborative su Web Categoria:Aziende multinazionali di servizi internet Categoria:E-learning Categoria:Voice over IP