Linkově lokální adresa () je adresa používaná síťovou vrstvou, pomocí které se dá komunikovat pouze v rámci toho segmentu sítě, ke kterému je připojeno dané síťové rozhraní určitého počítače.
Linkově lokální adresy jsou obvykle jednoznačné pouze v jednom segmentu sítě. Routery proto pakety s linkově lokální adresou nepřenášejí na jiné segmenty.
Linkově lokální adresy pro IPv4 jsou definovány v adresním bloku 169.254.0.0/16 v CIDR notaci. V IPv6 se používají adresy s prefixem fe80::/10.
Přidělení adres Jako jiné typy adres může být linkově lokální adresa přidělena ručně nebo automaticky. Některé protokoly podporují pouze automatickou konfiguraci.
V IP sítích je možno linkově lokální adresu obdržet nejčastěji použitím bezstavové konfigurace. V IPv4 jsou linkově lokální adresy obvykle použity pouze k přidělení IP adres zařízením pokud neexistuje žádný vnější mechanismus adresové konfigurace, jako např. DHCP nebo když jiná primární konfigurační metoda selže. V IPv6RFC 4291,IP Version 6 Addressing Architecture, R. Hinden, S. Deering, The Internet Society (February 2006) jsou linkově lokální adresy povinné a vyžadované pro vnitřní funkcionalitu řady protokolů.
IPv4 Podle RFC 3927 (Apple, Microsoft, Sun Microsystem) je pro linkově lokální adresování v IPv4 rezervován adresní blok 169.254.1.0 až 169.254.254.255. Pokud nejsou jiné možnosti, jsou linkově lokální adresy zařízením přiřazovány pomocí bezstavové konfigurace.RFC 3927, Dynamic Configuration of IPv4 Link-Local Addresses, S. Cheshire, B. Aboba, E. Guttman, The Internet Society (May 2005) Firma Microsoft odkazuje na tuto metodu jako na Automatic Private IP Addressing (APIPA).
RFC 3927 varuje před současným užíváním adres různého adresního prostoru, jako například konfigurování linkově lokálních adres a globálně směrovatelných adres na jednom rozhraní.RFC 3927 section 1.9 Proto připojená zařízení primárně hledají DHCP server, až poté přidělují linkově lokální adresu.
Při procesu automatické konfigurace vybírá síťové zařízení náhodnou adresu z rezervovaného adresního prostoru a pomocí Address Resolution Protocol (ARP) kontrolují, zda danou adresu nepoužívá jiná stanice. Pokud přijde ARP odpověď, znamená to, že zvolená adresa je již obsazena. V takovém případě musí zařízení vytvořit jinou náhodnou adresu a ověřit, zda není obsazena. Celý proces se opakuje tak dlouho, dokud nepřijde žádná ARP odpověď.
Pokud bude po přidělení linkově lokální adresy síťovému rozhraní přidělena globálně směrovatelná adresa nebo privátní adresa, měla by být pro další komunikaci preferována před linkově lokální adresou, avšak komunikace přes linkově lokální adresu je stále možná.RFC 3927 section 2.6.1
IPv6 V IPv6 byl pro linkově lokální unicast adresování rezervován adresní blok fe80::/10. Skutečná linkově lokální adresa je přidělena s prefixem fe80::/64.RFC 4291, section 2.5.6. Link-Local IPv6 Unicast Addresses. I když je tento blok rezervován pro linkově lokální adresy, musí být 54 bitů nastaveno na nulu. Prefix je proto fe80::/64 (RFC 4291, section 2.5.6.). Mohou být konfigurovány automaticky (stateless) nebo např. manuálně (stateful).
Na rozdíl od IPv4, IPv6 vyžaduje, aby byla linkově lokální adresa přidělena každému síťovému rozhraní, na kterém je IPv6 protokol povolen, i když je zároveň přidělena jedna nebo více směrovatelných adres.RFC 4291, section 2.8. A Node's Required Addresses To má za následek, že IPv6 zařízení většinou mívají pro každé rozhraní s povoleným IPv6 více než jednu IPv6 adresu. IPv6 adresa je potřeba například pro Neighbor Discovery Protocol a další protokoly založené na IPv6 jako DHCPv6.
V IPv6 je bezstavová konfigurace součástí Neighbor Discovery Protocol (NDP).RFC 4862, IPv6 Stateless Address Autoconfiguration, S. Thompson, T. Narten, T. Jinmei (September 2007) Adresa je bezstavovou konfigurací vytvořena z prefixu adres dané sítě a MAC adresy zařízení.
Reference (původní článek má již další revize)
Kategorie:Síťové adresy